PAPI Archivos

The PAPI authentication and authorization framework

PAPI@LISTSERV.REDIRIS.ES

Opciones: Vista Forum

Use Monospaced Font
Por defecto enseñar Text Part
Esconda cabeceras de correo

Mensaje: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Tema: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Autor: [<< Primero] [< Prev] [Siguiente >] [Último >>]

Print Responder
Received:
by LISTSERV.REDIRIS.ES (LISTSERV-TCP/IP release 14.5) with spool id 6175879 for [log in para visualizar]; Mon, 22 Jun 2009 13:20:43 +0200 from cain.rediris.es (cain.rediris.es [130.206.24.1]) by listserv.rediris.es (Postfix) with ESMTP id C0CE05C201 for <[log in para visualizar]>; Mon, 22 Jun 2009 13:20:42 +0200 (CEST) from chico.rediris.es (HELO chico) ([130.206.1.3]) by cain.rediris.es with ESMTP; 22 Jun 2009 13:14:22 +0200
X-Original-To:
Date:
Mon, 22 Jun 2009 13:20:42 +0200
Reply-To:
The PAPI authentication and authorization framework <[log in para visualizar]>
Subject:
Message-ID:
Content-Transfer-Encoding:
quoted-printable
Emisor:
Francisco Vivancos <[log in para visualizar]>
Sender:
The PAPI authentication and authorization framework <[log in para visualizar]>
Mime-Version:
1.0
Delivered-To:
Parts/Attachments:
text/plain (92 lines)
Hola, 

tengo configurado ya tanto el AS y el PoA(creo correctamente) para proteger
la aplicacion glpi que tengo, entonces he aadido en el listen.conf de
apache lo siguiente:


NameVirtualHost *:80
NameVirtualHost *:443
<VirtualHost *:80>
	ServerName localhost
	RedirectMatch (.*) https://localhost/cgi-bin/AuthServer
</VirtualHost>

<VirtualHost *:443>
	ServerName localhost
	ErrorDocument 404 https://localhost/cgi-bin/AuthServer
	RedirectMatch /index.html https://localhost/cgi-bin/AuthServer
	<IfModule mod_ssl.c>
		SSLEngine on
		SSLCertificateFile /etc/apache2/apache.pem
	</IfModule>

</VirtualHost>
<VirtualHost *:80>
            ServerName      poa.localhost
            DocumentRoot    "/srv/www/htdocs"
            DirectoryIndex  index.html index.php
            Options         Indexes
            ServerAdmin     admin@localhost
    
        <Location /glpi>
            PerlSetVar          Service_ID remoteform
            PerlOptions         +ParseHeaders
            SetHandler          perl-script
            PerlAccessHandler   PAPI::Main
        </Location>
</VirtualHost>

ahora intento arrancar el demonio del apache y me da el siguiente error:

Syntax error on line 73 of /etc/apache2/listen.conf:
Invalid command 'PerlSetVar', perhaps misspelled or defined by a module not
included in the server configuration

Yo pensaba que al instalar el modulo perl atraves del yast(SLES10), se
acoplaba solo al apache, pero al ir a mirar al archivo loadmodules.conf he
visto que no se encontraba.
Aado el modulo perl al arhivo que queda asi:

#
# Files in this directory are created at apache start time by
/usr/sbin/rcapache2 
# Do not edit them!
#

# as listed in APACHE_MODULES (/etc/sysconfig/apache2)

LoadModule actions_module         /usr/lib/apache2-prefork/mod_actions.so
LoadModule alias_module           /usr/lib/apache2-prefork/mod_alias.so
LoadModule auth_basic_module      /usr/lib/apache2-prefork/mod_auth_basic.so
LoadModule authn_file_module      /usr/lib/apache2-prefork/mod_authn_file.so
LoadModule authz_host_module      /usr/lib/apache2-prefork/mod_authz_host.so
LoadModule authz_groupfile_module        
/usr/lib/apache2-prefork/mod_authz_groupfile.so
LoadModule authz_default_module /usr/lib/apache2-prefork/mod_authz_default.so
LoadModule authz_user_module      /usr/lib/apache2-prefork/mod_authz_user.so
LoadModule authn_dbm_module       /usr/lib/apache2-prefork/mod_authn_dbm.so
LoadModule autoindex_module       /usr/lib/apache2-prefork/mod_autoindex.so
LoadModule cgi_module             /usr/lib/apache2-prefork/mod_cgi.so
LoadModule dir_module             /usr/lib/apache2-prefork/mod_dir.so
LoadModule env_module             /usr/lib/apache2-prefork/mod_env.so
LoadModule expires_module         /usr/lib/apache2-prefork/mod_expires.so
LoadModule include_module         /usr/lib/apache2-prefork/mod_include.so
LoadModule log_config_module      /usr/lib/apache2-prefork/mod_log_config.so
LoadModule mime_module            /usr/lib/apache2-prefork/mod_mime.so
LoadModule negotiation_module    /usr/lib/apache2-prefork/mod_negotiation.so
LoadModule setenvif_module        /usr/lib/apache2-prefork/mod_setenvif.so
LoadModule ssl_module             /usr/lib/apache2-prefork/mod_ssl.so
LoadModule suexec_module          /usr/lib/apache2-prefork/mod_suexec.so
LoadModule userdir_module         /usr/lib/apache2-prefork/mod_userdir.so
LoadModule php5_module            /usr/lib/apache2/mod_php5.so
LoadModule perl_module            /usr/lib/apache2/mod_perl.so
#

Vuelvo a intentar arrancar el apache pero sigue dandome el mismo error.

Sabe alguien que puede estar pasando o si me falta aadir alguna cosa mas?

Gracias.
Un Saludo.Francisco.

ATOM RSS1 RSS2