PAPI Archivos

The PAPI authentication and authorization framework

PAPI@LISTSERV.REDIRIS.ES

Opciones: Vista Forum

Use Monospaced Font
Por defecto enseñar Text Part
Mostrar todas las cabeceras de correo

Mensaje: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Tema: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Autor: [<< Primero] [< Prev] [Siguiente >] [Último >>]

Print Responder
Subject:
Emisor:
Jorge López Pérez <[log in para visualizar]>
Reply To:
The PAPI authentication and authorization framework <[log in para visualizar]>
Fecha:
Tue, 14 Oct 2008 13:47:55 +0200
Content-Type:
text/plain
Parts/Attachments:
text/plain (65 lines)
Hola a todos,

 sigo aqu intentando configurar, usando PAPI 1.5, un AS + PoA. Ya tengo
 funcionando el AS, y ahora me encuentro con una pequea dificultad al
 instalar el PoA.

 El AS est en host:8888 y estoy intentando que el PoA se encuentre en
 host:80/poa. Siguiendo la gua de configuracin del PoA para PAPI 1.5
 (https://forja.rediris.es/docman/view.php/42/447/PAPI_PoA-Config.html),
 al acceder al PoA obtengo en el navegador un error 500, y en los logs
 de Apache lo siguiente:

  [Tue Oct 14 13:33:27 2008] [notice] [client 150.214.142.56]
  PAPI#27055_1223984007: PoA::set_parameters# Servername =
  <host>\n, referer:
  http://host:8888/cgi-bin/AuthServer
  [Tue Oct 14 13:33:27 2008] [notice] [client 150.214.142.56]
  PAPI#27055_1223984007: PoA::set_parameters# Server_ID = <prueba>\n,
  referer: http://host:8888/cgi-bin/AuthServer
  [Tue Oct 14 13:33:27 2008] [error] [client 150.214.142.56]
  PAPI#27055_1223984007: Apache Server_ID = <prueba>, referer:
  http://host:8888/cgi-bin/AuthServer
  [Tue Oct 14 13:33:27 2008] [error] [client 150.214.142.56]
  PAPI#27055_1223984007: PAPI XML Service_ID = <>, referer:
  http://host:8888/cgi-bin/AuthServer
  [Tue Oct 14 13:33:27 2008] [error] [client 150.214.142.56]
  PAPI#27055_1223984007: Can't instance a new PoA, the Service_ID from
  Apache conf. is not equal to the id for the Location from PAPI XML
  configuration file., referer:
  http://host:8888/cgi-bin/AuthServer

 Parece que no est funcionando la directiva PerlSetVar. Os pongo la
 parte de la configuracin ms relevante, por si alguien detectase algn
 error :) :

--8<--

 httpd.conf:

  <VirtualHost *:80>
   ...
   <Location /poa>
    PerlSetVar          Service_ID prueba
    PerlOptions         +ParseHeaders
    SetHandler          perl-script
    PerlAccessHandler   PAPI::Main
   </Location>
  </VirtualHost>
 
 papi_conf.xml:
  
  <Server name="host" port="80" independent="0">
   <Location path="/poa" id="prueba">
    <PAPI_AS id="PAPIpreprod" url="http://host:8888/AS">PAPI preproducci on</PAPI_AS> 
    <GPoA_URL>wayf:built-in</GPoA_URL>
   </Location>
  </Server>

-->8--

 Gracias de nuevo, un saludo.
-- 
Jorge Lpez Prez
jabber: [log in para visualizar]

ATOM RSS1 RSS2