PAPI Archivos

The PAPI authentication and authorization framework

PAPI@LISTSERV.REDIRIS.ES

Opciones: Vista Forum

Use Monospaced Font
Por defecto enseñar Text Part
Mostrar todas las cabeceras de correo

Mensaje: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Tema: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Autor: [<< Primero] [< Prev] [Siguiente >] [Último >>]

Print Responder
Subject:
Emisor:
Francisco Vivancos <[log in para visualizar]>
Reply To:
The PAPI authentication and authorization framework <[log in para visualizar]>
Fecha:
Tue, 30 Jun 2009 10:57:44 +0200
Content-Type:
text/plain
Parts/Attachments:
text/plain (70 lines)
Hola,

por lo visto tengo problemas con las claves.

las claves las creo con:
openssl genrsa -out MyAS_privkey.pem 1024
openssl genrsa -in MyAS_privkey.pem -pubout -out MyAS_pubkey.pem

en el Authserver tengo:

$$cfg{workingDirectory} = '/usr/local/PAPI/AS/etc';
## Properties of this AS that must be configured in the PoA(s).
$$cfg{asLocation} = 'https://localhost/cgi-bin/AuthServer';
$$cfg{serverID} = 'MyAS';
# YOU MUST GENERATE THIS FILE AND THE CORRESPONDING PUBLIC KEY
# It is the pubkey what must be sent to tha PoA(s), and stored
# (in the case of mod_perl PoAs) as $Pubkeys_Path/${serverID}_pubkey.pem
$$cfg{privateKey} = 'MyAS_privkey.pem';

linux:/usr/local/PAPI # ls /usr/local/PAPI/AS/etc/MyAS_privkey.pem
/usr/local/PAPI/AS/etc/MyAS_privkey.pem

en el conf.xml tengo:
<HKey>7aae711d93ba0ed610f791614892f9ce</HKey>

<LKey>0ee1e5adc0847a62eaf55caa8a1f3f60</LKey>

<Pubkeys_Path>/usr/local/PAPI/PoA/KEYS</Pubkeys_Path>

linux:/usr/local/PAPI # ls /usr/local/PAPI/PoA/KEYS/MyAS_pubkey.pem
/usr/local/PAPI/PoA/KEYS/MyAS_pubkey.pem

el log de apache muestra:

[Tue Jun 30 11:12:49 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353169: PoA::set_parameters# Servername = <poa.localhost>\n
[Tue Jun 30 11:12:49 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353169: PoA::set_parameters# Server_ID = <glpi>\n
[Tue Jun 30 11:12:49 2009] [warn] [client 127.0.0.1]
PAPI#10448_1246353169_glpi: Lcook is empty
[Tue Jun 30 11:12:49 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353169_glpi: Hcook is empty
[Tue Jun 30 11:12:49 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353169: PoA::set_parameters# Servername = <poa.localhost>\n
[Tue Jun 30 11:12:49 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353169: PoA::set_parameters# Server_ID = <glpi>\n
[Tue Jun 30 11:12:49 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353169: PoA::set_parameters# Servername = <poa.localhost>\n
[Tue Jun 30 11:12:49 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353169: PoA::set_parameters# Server_ID = <glpi>\n
[Tue Jun 30 11:12:50 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353170: PoA::set_parameters# Servername = <poa.localhost>\n
[Tue Jun 30 11:12:50 2009] [notice] [client 127.0.0.1]
PAPI#10448_1246353170: PoA::set_parameters# Server_ID = <glpi>\n
[Tue Jun 30 11:12:50 2009] [warn] [client 127.0.0.1]
PAPI#10448_1246353170_glpi: Authentication ERROR received from GPoA
wayf:built-in
[Tue Jun 30 11:12:50 2009] [warn] [client 127.0.0.1]
PAPI#10448_1246353170_glpi: Invalid GPoA/PAS Answer for /glpi/


no encuentra ni la lcook ni Hcook y tambien tengo el error del
authenticacion del GPoA que creo es por las claves generadas

Alguien tiene alguna idea de lo que esta pasando?

Gracias.
Un Saludo.
Francisco.

ATOM RSS1 RSS2