PAPI Archivos

The PAPI authentication and authorization framework

PAPI@LISTSERV.REDIRIS.ES

Opciones: Vista Forum

Use Monospaced Font
Mostrar las partes HTML
Mostrar todas las cabeceras de correo

Mensaje: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Tema: [<< Primero] [< Prev] [Siguiente >] [Último >>]
Autor: [<< Primero] [< Prev] [Siguiente >] [Último >>]

Print Responder
Subject:
Emisor:
Antonio José García Lagar <[log in para visualizar]>
Reply To:
The PAPI authentication and authorization framework <[log in para visualizar]>
Fecha:
Thu, 8 Jan 2009 08:50:31 +0100
Content-Type:
text/plain
Parts/Attachments:
text/plain (36 lines)
En los cambios hechos en la revisión 113 ( 
https://forja.rediris.es/plugins/scmsvn/viewcvs.php/trunk/PoA/PoA.pm?root=papi-
perl&r1=84&r2=113 ), se cambia la Hcook_DB de formato MLDBM a DB_File.

Hay que agregar las nuevas dependencias (en mi sistema he tenido que agregar 
al menos DB_File::Lock).

A parte de ello, al intentar conectar a un poa obtengo esto en el log del 
apache2:
failed to resolve handler `PAPI::Main': Global symbol "$locking" requires 
explicit package name at /usr/local/share/perl/5.10.0/PAPI/PoA.pm line 727.
\nGlobal symbol "$locking" requires explicit package name at 
/usr/local/share/perl/5.10.0/PAPI/PoA.pm line 741.\nBEGIN not safe after 
errors--compilation aborted at /usr/local/share/perl/5.10.0/PAPI/PoA.pm line 
835.\nCompilation failed in require at 
/usr/local/share/perl/5.10.0/PAPI/ApachePoA.pm line 10.\nBEGIN failed--
compilation aborted at /usr/local/share/perl/5.10.0/PAPI/ApachePoA.pm line 10.
\nCompilation failed in require at /usr/local/share/perl/5.10.0/PAPI/Main.pm 
line 8.\nBEGIN failed--compilation aborted at 
/usr/local/share/perl/5.10.0/PAPI/Main.pm line 8.\nCompilation failed in 
require at (eval 411) line 3.\n



El Wednesday 07 January 2009 12:27:54 Antonio José García Lagar escribió:
> Revisando en el repositorio los últimos cambios al PAPI a raíz de la
> publicación de la rc3, he visto que para corregir el problema existente con
> el método expandAssertion se ha aplicado un parche de forma incorrecta
> (revision 116).
>
> Podéis verlo en:
> https://forja.rediris.es/plugins/scmsvn/viewcvs.php/trunk/LDAPAuth/LDAPAuth
>.pm?root=papi- perl&r1=110&r2=116
>
> Un saludo.

ATOM RSS1 RSS2